Saturday, November 30, 2013

Upgrade SVN client in older ubuntu versions

Ubuntu LTS version[12.04] doesn't have svn client 1.7 installed. If you tried to use a newer svn local repository with default version, you get an error:

This is the fix:

sudo apt-add-repository ppa:dominik-stadler/subversion-1.7
If you already have subversion previous intalled, remove it
sudo apt-get remove subversion
sudo apt-get update
Now, reinstalling subversion will fix your issue. But it may required to download some files [about 4 MB] from subversion site.
sudo apt-get install subversion

No comments:

Post a Comment